mirror of
https://github.com/ptitSeb/box64.git
synced 2024-11-23 06:30:22 +00:00
b3b84f8357
* Latest batch of PKGBUILD updates - New platforms added - Combined PKGBUILD for all Raspberry Pi devices - Combined PKGBUILD for all RockChip devices * Fixes - Fix arch in rv64 and x86_64 - Remove la64 since arch linux not available for platform * No LARCH64 PKGBUILD
37 lines
1.1 KiB
Plaintext
37 lines
1.1 KiB
Plaintext
# Maintainer: Jai-JAP <jai.jap.318@gmail.com>
|
|
# Author: Sebastien Chevalier <ptitseb@box86.org>
|
|
pkgname=box64-phytium-git
|
|
pkgver=r2431.60c6858
|
|
pkgrel=1
|
|
pkgdesc="Linux Userspace x86_64 Emulator with a twist, targeted at ARM64 Linux devices."
|
|
arch=('aarch64')
|
|
url="https://github.com/ptitSeb/box64"
|
|
license=('MIT')
|
|
optdepends=('gl4es: OpenGL 2 for GLES 2 devices')
|
|
makedepends=('git' 'cmake' 'make')
|
|
provides=("${pkgname%-git}" "${pkgname%-phytium-git}-git" "${pkgname%-phytium-git}")
|
|
conflicts=("${pkgname%-git}" "${pkgname%-phytium-git}-git" "${pkgname%-phytium-git}")
|
|
source=('git+https://github.com/ptitSeb/box64')
|
|
md5sums=('SKIP')
|
|
|
|
pkgver() {
|
|
cd "${srcdir}/${pkgname%-phytium-git}"
|
|
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
|
|
}
|
|
|
|
prepare() {
|
|
cd "${srcdir}/${pkgname%-phytium-git}"
|
|
[[ ! -d ./build ]] && mkdir build
|
|
cmake -B build -DPHYTIUM=ON -DCMAKE_BUILD_TYPE=RelWithDebInfo -DCMAKE_INSTALL_PREFIX=/usr
|
|
}
|
|
|
|
build() {
|
|
cd "${srcdir}/${pkgname%-phytium-git}/build"
|
|
make -j$(nproc)
|
|
}
|
|
|
|
package() {
|
|
cd "${srcdir}/${pkgname%-phytium-git}/build"
|
|
make DESTDIR="${pkgdir}/" install
|
|
}
|