mirror of
https://github.com/HeyPuter/firefox.git
synced 2026-11-13 20:14:57 -10:00
We're going to update the MSRV to 1.90 soon, and we might as well remove the hacks we have in place from bug 1982939 and bug 1995920 for vendoring backwards compatibility early. Differential Revision: https://phabricator.services.mozilla.com/D279628
This library provides the following common encodings:
| Name | Description |
|---|---|
HEXLOWER |
lowercase hexadecimal |
HEXLOWER_PERMISSIVE |
lowercase hexadecimal (case-insensitive decoding) |
HEXUPPER |
uppercase hexadecimal |
HEXUPPER_PERMISSIVE |
uppercase hexadecimal (case-insensitive decoding) |
BASE32 |
RFC4648 base32 |
BASE32_NOPAD |
RFC4648 base32 (no padding) |
BASE32_DNSSEC |
RFC5155 base32 |
BASE32_DNSCURVE |
DNSCurve base32 |
BASE32HEX |
RFC4648 base32hex |
BASE32HEX_NOPAD |
RFC4648 base32hex (no padding) |
BASE64 |
RFC4648 base64 |
BASE64_NOPAD |
RFC4648 base64 (no padding) |
BASE64_MIME |
RFC2045-like base64 |
BASE64URL |
RFC4648 base64url |
BASE64URL_NOPAD |
RFC4648 base64url (no padding) |
It also provides the possibility to define custom little-endian ASCII base-conversion encodings for bases of size 2, 4, 8, 16, 32, and 64 (for which all above use-cases are particular instances).
See the documentation for more details.