vcpkg/ports/ceres/0001_add_missing_include_path.patch
Victor Romero e03ee9cace
[ceres,jxrlib,zziplib] Fixes for non-windows (#6188)
* [ceres, zziplib] fixes for building on non-windows systems

* [jxrlib, zziplib] other fixes for non-windows systems

* [zziplib] fix CMakeLists.txt for non win32 platforms, there were missing exported headers

* [ceres] Fix targets path

* [ceres] Fix typo

* [ceres] trigger CI build

* [ceres] use proper glog/gflags targets
2019-04-30 16:54:33 -07:00

14 lines
526 B
Diff

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 02c72b5..15a947e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -582,7 +582,7 @@ include_directories(
# Note that this is *not* propagated to clients, ie CERES_INCLUDE_DIRS
# used by clients after find_package(Ceres) does not identify Eigen as
# as system headers.
-include_directories(SYSTEM ${EIGEN_INCLUDE_DIRS})
+include_directories(SYSTEM ${EIGEN_INCLUDE_DIRS} ${EIGEN_INCLUDE_DIRS}/Eigen)
if (SUITESPARSE)
include_directories(${SUITESPARSE_INCLUDE_DIRS})