vcpkg/ports/curl/0009_fix_openssl_config.patch
Jack·Boos·Yu d4c6627acd
[curl] Set non-http as default feature (#9613)
* [curl] Set non-http as default feature

* [curl] rebuild code

* [curl] Add error info, disable uwp build when selecting feature winssl,sspi,tool

* [curl] Remove deprecated function

* [curl] Fix openssl dependency check in config.cmake
2020-02-04 14:40:19 -08:00

13 lines
354 B
Diff

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 42e490a..ec9e4d1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -348,6 +348,7 @@ if(CMAKE_USE_SECTRANSP)
list(APPEND CURL_LIBS "${COREFOUNDATION_FRAMEWORK}" "${SECURITY_FRAMEWORK}")
endif()
+set(USE_OPENSSL OFF)
if(CMAKE_USE_OPENSSL)
find_package(OpenSSL REQUIRED)
set(SSL_ENABLED ON)