vcpkg/ports/discount/disable-deprecated-warnings.patch
Tri Tran 8390d68837 [discount] Add new package Discount (#7400)
* [discount] Add new package Discount

* [discount] Add new package Discount

* New package [Discount](https://github.com/Orc/discount)

* Static build only

* [discount] Fix arm* and *uwp builds

* Discount needs to run `mktags.exe` to generate `blocktags`. This fix copy generated `blocktags` to `SOURCE_PATH` for arm\* builds and \*uwp builds.

* [discount] Fix UWP and ARM check

* [discount] Another fix for blocktags

* [discount] And another one

* [discount] And another one. Please squash these PR commits.

Sorry I don't have UWP or ARM compiler installed on my machine.

* [discount] Use definitions in msvc/Makefile

* [discount] Add homepage
2019-08-08 12:04:39 -04:00

17 lines
587 B
Diff

diff --git a/cmake/CMakeLists.txt b/cmake/CMakeLists.txt
index 11fa675..34cc9ed 100644
--- a/cmake/CMakeLists.txt
+++ b/cmake/CMakeLists.txt
@@ -20,6 +20,11 @@ set(${PROJECT_NAME}_INSTALL_SAMPLES OFF CACHE BOOL
set(${PROJECT_NAME}_ONLY_LIBRARY OFF CACHE BOOL
"Set to ON to only build markdown library (default is OFF)")
+# MSVC deprecated warnings (C4996,strdup, ...)
+if(MSVC)
+ add_definitions(-D_CRT_SECURE_NO_DEPRECATE -D_CRT_NONSTDC_NO_DEPRECATE -D_SCL_SECURE_NO_WARNINGS)
+endif()
+
# Check headers
include(CheckIncludeFile)
check_include_file(libgen.h HAVE_LIBGEN_H)