mirror of
https://github.com/reactos/wine.git
synced 2025-03-07 04:09:16 +00:00

Thu May 16 13:35:31 1996 Alexandre Julliard <julliard@lrc.epfl.ch> * [*/*.c] Renamed RECT, POINT and SIZE structures to RECT16, POINT16 and SIZE16. Implemented Win32 version of most functions that take these types as parameters. * [configure] Patched autoconf to attempt to correctly detect -lnsl and -lsocket. Please check this out. * [controls/button.c] Added support for Win32 BM_* messages. * [controls/menu.c] Avoid sending extra WM_MENUSELECT messages. This avoids crashes with Excel. * [memory.heap.c] [include/heap.h] Added support for SEGPTRs in Win32 heaps. Added a few macros to make using SEGPTRs easier. They are a bit slower than MAKE_SEGPTR, but they work with Win32. * [memory/atom.c] Implemented Win32 atom functions. * [memory/local.c] Fixed LocalReAlloc() changes to avoid copying the whole block twice. * [win32/memory.c] Use /dev/zero instead of MAP_ANON for VirtualAlloc(). * [windows/class.c] Properly implemented the Win32 class functions. * [windows/winproc.c] (New file) New file handling the message translation between Win16 and Win32. Mon May 13 18:00:00 1996 Alex Korobka <alex@phm30.pharm.sunysb.edu> * [windows/mdi.c] [windows/menu.c] Improved WM_MDICREATE and WM_MDICASCADE handling. * [windows/event.c] [objects/bitblt.c] Handle GraphicsExpose event for BitBlt from screen to screen. * [windows/event.c] [windows/win.c] [windows/nonclient.c] Bunch of fixes for problems with -managed. * [windows/win.c] [windows/winpos.c] Changed conditions for WM_SIZE, WM_MOVE, and WM_GETMINMAXINFO in CreateWindow. * [windows/win.c] [windows/queue.c] [misc/user.c] Do not send WM_PARENTNOTIFY when in AppExit and call WH_SHELL on window creation/destruction. * [objects/palette.c] Crude RealizePalette(). At least something is visible in LviewPro. Sun May 12 02:05:00 1996 Thomas Sandford <t.d.g.sandford@prds-grn.demon.co.uk> * [if1632/gdi32.spec] Added Rectangle (use win16 version). * [if1632/kernel32.spec] Added GetWindowsDirectoryA (use win16 GetWindowsDirectory). * [if1632/user32.spec] Added GetSubMenu, MoveWindow, SetScrollPos, SetScrollRange (use win16 versions). Added SetWindowsHookExA (empty stub for now). * [include/handle32.h] Changed #include <malloc.h> to #include <stdlib.h> to prevent hate message from FreeBSD compiler. * [win32/newfns.c] Added new function SetWindowsHookEx32A (empty stub for now). * [win32/user32.c] Removed redundant debugging printf statement. Sun May 12 01:24:57 1996 Huw D. M. Davies <h.davies1@physics.oxford.ac.uk> * [memory/local.c] Avoid creating adjacent free blocks. Free the block in LocalReAlloc() before allocating a new one. Fixed LocalReAlloc() for discarded blocks. Fri May 10 23:05:12 1996 Jukka Iivonen <iivonen@cc.helsinki.fi> * [resources/sysres_Fi.rc] ChooseFont and ChooseColor dialogs updated. Fri May 10 17:19:33 1996 Marcus Meissner <msmeissn@cip.informatik.uni-erlangen.de> * [files/drive.c,if1632/kernel.spec] GetCurrentDirectory(),SetCurrentDirectory() implemented. * [if1632/advapi32.spec] [if1632/kernel.spec] [if1632/shell.spec] [include/windows.h] [include/winreg.h] [loader/main.c] [misc/main.c] [misc/shell.c] [misc/registry.c] Registry fixes: - loads win95 registry databases, - save only updated keys on default, - now adhers to the new function naming standard, - minor cleanups. Tue May 7 22:36:13 1996 Albrecht Kleine <kleine@ak.sax.de> * [combo.c] Added WM_COMMAND-handling for interaction between EDIT and COMBOLBOX and synchronized mine with Greg Kreider's works. * [commdlg.c] Bugfix in ChooseFont: font size handling.
130 lines
6.9 KiB
Ruby
130 lines
6.9 KiB
Ruby
name mmsystem
|
|
type win16
|
|
|
|
#1 pascal MMSYSTEM_WEP(word word word ptr) MMSYSTEM_WEP
|
|
2 pascal SNDPLAYSOUND(ptr word) sndPlaySound
|
|
5 pascal MMSYSTEMGETVERSION() mmsystemGetVersion
|
|
6 pascal DriverProc(long word word long long) DriverProc
|
|
30 pascal16 OutputDebugStr(ptr) OutputDebugString
|
|
31 pascal DriverCallback(long word word word long long long)
|
|
DriverCallback
|
|
#32 pascal STACKENTER
|
|
#33 pascal STACKLEAVE
|
|
#34 pascal MMDRVINSTALL
|
|
101 pascal JOYGETNUMDEVS() JoyGetNumDevs
|
|
102 pascal JOYGETDEVCAPS(word ptr word) JoyGetDevCaps
|
|
103 pascal JOYGETPOS(word ptr) JoyGetPos
|
|
104 pascal JOYGETTHRESHOLD(word ptr) JoyGetThreshold
|
|
105 pascal JOYRELEASECAPTURE(word) JoyReleaseCapture
|
|
106 pascal JOYSETCAPTURE(word word word word) JoySetCapture
|
|
107 pascal JOYSETTHRESHOLD(word word) JoySetThreshold
|
|
109 pascal JOYSETCALIBRATION(word) JoySetCalibration
|
|
201 pascal MIDIOUTGETNUMDEVS() midiOutGetNumDevs
|
|
202 pascal MIDIOUTGETDEVCAPS(word segptr word) midiOutGetDevCaps
|
|
203 pascal MIDIOUTGETERRORTEXT(word ptr word) midiOutGetErrorText
|
|
204 pascal MIDIOUTOPEN(ptr word ptr long long long) midiOutOpen
|
|
205 pascal MIDIOUTCLOSE(word) midiOutClose
|
|
206 pascal MIDIOUTPREPAREHEADER(word segptr word) midiOutPrepareHeader
|
|
207 pascal MIDIOUTUNPREPAREHEADER(word segptr word) midiOutUnprepareHeader
|
|
208 pascal MIDIOUTSHORTMSG(word long) midiOutShortMsg
|
|
209 pascal MIDIOUTLONGMSG(word ptr word) midiOutLongMsg
|
|
210 pascal MIDIOUTRESET(word) midiOutReset
|
|
211 pascal MIDIOUTGETVOLUME(word segptr) midiOutGetVolume
|
|
212 pascal MIDIOUTSETVOLUME(word long) midiOutSetVolume
|
|
213 pascal MIDIOUTCACHEPATCHES(word word segptr word) midiOutCachePatches
|
|
214 pascal MIDIOUTCACHEDRUMPATCHES(word word segptr word) midiOutCacheDrumPatches
|
|
215 pascal MIDIOUTGETID(word ptr) midiOutGetID
|
|
216 pascal MIDIOUTMESSAGE(word word long long) midiOutMessage
|
|
301 pascal MIDIINGETNUMDEVS() midiInGetNumDevs
|
|
302 pascal MIDIINGETDEVCAPS(word segptr word) midiInGetDevCaps
|
|
303 pascal MIDIINGETERRORTEXT(word ptr word) midiInGetErrorText
|
|
304 pascal MIDIINOPEN(ptr word ptr long long long) midiInOpen
|
|
305 pascal MIDIINCLOSE(word) midiInClose
|
|
306 pascal MIDIINPREPAREHEADER(word segptr word) midiInPrepareHeader
|
|
307 pascal MIDIINUNPREPAREHEADER(word segptr word) midiInUnprepareHeader
|
|
309 pascal MIDIINSTART(word) midiInStart
|
|
310 pascal MIDIINSTOP(word) midiInStop
|
|
311 pascal MIDIINRESET(word) midiInReset
|
|
312 pascal MIDIINGETID(word ptr) midiInGetID
|
|
313 pascal MIDIINMESSAGE(word word long long) midiInMessage
|
|
350 pascal AUXGETNUMDEVS() auxGetNumDevs
|
|
351 pascal AUXGETDEVCAPS(word segptr word) auxGetDevCaps
|
|
352 pascal AUXGETVOLUME(word segptr) auxGetVolume
|
|
353 pascal AUXSETVOLUME(word long) auxSetVolume
|
|
354 pascal AUXOUTMESSAGE(word word long long) auxOutMessage
|
|
401 pascal WAVEOUTGETNUMDEVS() waveOutGetNumDevs
|
|
402 pascal WAVEOUTGETDEVCAPS(word segptr word) waveOutGetDevCaps
|
|
403 pascal WAVEOUTGETERRORTEXT(word ptr word) waveOutGetErrorText
|
|
404 pascal WAVEOUTOPEN(ptr word ptr long long long) waveOutOpen
|
|
405 pascal WAVEOUTCLOSE(word) waveOutClose
|
|
406 pascal WAVEOUTPREPAREHEADER(word segptr word) waveOutPrepareHeader
|
|
407 pascal WAVEOUTUNPREPAREHEADER(word segptr word) waveOutUnprepareHeader
|
|
408 pascal WAVEOUTWRITE(word segptr word) waveOutWrite
|
|
409 pascal WAVEOUTPAUSE(word) waveOutPause
|
|
410 pascal WAVEOUTRESTART(word) waveOutRestart
|
|
411 pascal WAVEOUTRESET(word) waveOutReset
|
|
412 pascal WAVEOUTGETPOSITION(word segptr word) waveOutGetPosition
|
|
413 pascal WAVEOUTGETPITCH(word ptr) waveOutGetPitch
|
|
414 pascal WAVEOUTSETPITCH(word long) waveOutSetPitch
|
|
415 pascal WAVEOUTGETVOLUME(word segptr) waveOutGetVolume
|
|
416 pascal WAVEOUTSETVOLUME(word long) waveOutSetVolume
|
|
417 pascal WAVEOUTGETPLAYBACKRATE(word ptr) waveOutGetPlaybackRate
|
|
418 pascal WAVEOUTSETPLAYBACKRATE(word long) waveOutSetPlaybackRate
|
|
419 pascal WAVEOUTBREAKLOOP(word) waveOutBreakLoop
|
|
420 pascal WAVEOUTGETID(word ptr) waveOutGetID
|
|
421 pascal WAVEOUTMESSAGE(word word long long) waveOutMessage
|
|
501 pascal WAVEINGETNUMDEVS() waveInGetNumDevs
|
|
502 pascal WAVEINGETDEVCAPS(word segptr word) waveInGetDevCaps
|
|
503 pascal WAVEINGETERRORTEXT(word ptr word) waveInGetErrorText
|
|
504 pascal WAVEINOPEN(ptr word ptr long long long) waveInOpen
|
|
505 pascal WAVEINCLOSE(word) waveInClose
|
|
506 pascal WAVEINPREPAREHEADER(word segptr word) waveInPrepareHeader
|
|
507 pascal WAVEINUNPREPAREHEADER(word segptr word) waveInUnprepareHeader
|
|
508 pascal WAVEINADDBUFFER(word segptr word) waveInAddBuffer
|
|
509 pascal WAVEINSTART(word) waveInStart
|
|
510 pascal WAVEINSTOP(word) waveInStop
|
|
511 pascal WAVEINRESET(word) waveInReset
|
|
512 pascal WAVEINGETPOSITION(word segptr word) waveInGetPosition
|
|
513 pascal WAVEINGETID(word ptr) waveInGetID
|
|
514 pascal WAVEINMESSAGE(word word long long) waveInMessage
|
|
601 pascal timeGetSystemTime(ptr word) timeGetSystemTime
|
|
602 pascal timeSetEvent(word word segptr long word) timeSetEvent
|
|
603 pascal timeKillEvent(word) timeKillEvent
|
|
604 pascal timeGetDevCaps(ptr word) timeGetDevCaps
|
|
605 pascal timeBeginPeriod(word) timeBeginPeriod
|
|
606 pascal timeEndPeriod(word) timeEndPeriod
|
|
607 pascal timeGetTime() timeGetTime
|
|
701 pascal MCISENDCOMMAND(word word long long) mciSendCommand
|
|
702 pascal MCISENDSTRING(ptr ptr word word) mciSendString
|
|
703 pascal MCIGETDEVICEID(ptr) mciSendCommand
|
|
706 pascal MCIGETERRORSTRING(long ptr word) mciGetErrorString
|
|
#900 pascal MMTASKCREATE
|
|
#902 pascal MMTASKBLOCK
|
|
#903 pascal MMTASKSIGNAL
|
|
#904 pascal MMGETCURRENTTASK
|
|
#905 pascal MMTASKYIELD
|
|
1100 pascal DRVOPEN(ptr ptr long) DrvOpen
|
|
1101 pascal DRVCLOSE(word long long) DrvClose
|
|
1102 pascal DRVSENDMESSAGE(word word long long) DrvSendMessage
|
|
1103 pascal DRVGETMODULEHANDLE(word) DrvGetModuleHandle
|
|
1104 pascal DRVDEFDRIVERPROC(long word word long long) DrvDefDriverProc
|
|
1210 pascal MMIOOPEN(ptr ptr long) mmioOpen
|
|
1211 pascal MMIOCLOSE(word word) mmioClose
|
|
1212 pascal MMIOREAD(word ptr long) mmioRead
|
|
1213 pascal MMIOWRITE(word ptr long) mmioWrite
|
|
1214 pascal MMIOSEEK(word long word) mmioSeek
|
|
1215 pascal MMIOGETINFO(word ptr word) mmioGetInfo
|
|
1216 pascal MMIOSETINFO(word ptr word) mmioSetInfo
|
|
1217 pascal MMIOSETBUFFER(word ptr long word) mmioSetBuffer
|
|
1218 pascal MMIOFLUSH(word word) mmioFlush
|
|
1219 pascal MMIOADVANCE(word ptr word) mmioAdvance
|
|
1220 pascal MMIOSTRINGTOFOURCC(ptr word) mmioStringToFOURCC
|
|
1221 pascal MMIOINSTALLIOPROC(long ptr long) mmioInstallIOProc
|
|
1222 pascal MMIOSENDMESSAGE(word word long long) mmioSendMessage
|
|
1223 pascal MMIODESCEND(word ptr ptr word) mmioDescend
|
|
1224 pascal MMIOASCEND(word ptr word) mmioAscend
|
|
1225 pascal MMIOCREATECHUNK(word ptr word) mmioCreateChunk
|
|
1226 pascal MMIORENAME(ptr ptr ptr long) mmioRename
|
|
|
|
|