mirror of
https://github.com/TechnitiumSoftware/DnsServer.git
synced 2026-10-12 02:09:51 +00:00
94 lines
5.9 KiB
Markdown
94 lines
5.9 KiB
Markdown
# Supported RFCs
|
|
|
|
The following is a list of RFCs that Technitium DNS Server implements.
|
|
|
|
| RFC | Title |
|
|
|----------|-----------------------------------------------------------------------------------------------------------------|
|
|
| RFC 1034 | Domain names - concepts and facilities
|
|
| RFC 1035 | Domain names - implementation and specification
|
|
| RFC 1183 | New DNS RR Definitions
|
|
| RFC 1982 | Serial Number Arithmetic
|
|
| RFC 1995 | Incremental Zone Transfer in DNS
|
|
| RFC 1996 | A Mechanism for Prompt Notification of Zone Changes (DNS NOTIFY)
|
|
| RFC 1886 | DNS Extensions to support IP version 6
|
|
| RFC 2136 | Dynamic Updates in the Domain Name System (DNS UPDATE)
|
|
| RFC 2308 | Negative Caching of DNS Queries (DNS NCACHE)
|
|
| RFC 2782 | A DNS RR for specifying the location of services (DNS SRV)
|
|
| RFC 2845 | Secret Key Transaction Authentication for DNS (TSIG)
|
|
| RFC 2915 | The Naming Authority Pointer (NAPTR) DNS Resource Record
|
|
| RFC 3123 | A DNS RR Type for Lists of Address Prefixes (APL RR)
|
|
| RFC 3225 | Indicating Resolver Support of DNSSEC
|
|
| RFC 3596 | DNS Extensions to Support IP Version 6
|
|
| RFC 3597 | Handling of Unknown DNS Resource Record (RR) Types
|
|
| RFC 4033 | DNS Security Introduction and Requirements
|
|
| RFC 4034 | Resource Records for the DNS Security Extensions
|
|
| RFC 4035 | Protocol Modifications for the DNS Security Extensions
|
|
| RFC 4255 | Using DNS to Securely Publish Secure Shell (SSH) Key Fingerprints
|
|
| RFC 4509 | Use of SHA-256 in DNSSEC Delegation Signer (DS) Resource Records (RRs)
|
|
| RFC 4592 | The Role of Wildcards in the Domain Name System
|
|
| RFC 4635 | HMAC SHA (Hashed Message Authentication Code, Secure Hash Algorithm) TSIG Algorithm Identifiers
|
|
| RFC 4697 | Observed DNS Resolution Misbehavior
|
|
| RFC 5155 | DNS Security (DNSSEC) Hashed Authenticated Denial of Existence
|
|
| RFC 5452 | Measures for Making DNS More Resilient against Forged Answers
|
|
| RFC 5702 | Use of SHA-2 Algorithms with RSA in DNSKEY and RRSIG Resource Records for DNSSEC
|
|
| RFC 5782 | DNS Blacklists and Whitelists
|
|
| RFC 5891 | Internationalized Domain Names in Applications (IDNA): Protocol
|
|
| RFC 5936 | DNS Zone Transfer Protocol (AXFR)
|
|
| RFC 5966 | DNS Transport over TCP - Implementation Requirements
|
|
| RFC 6147 | DNS64: DNS Extensions for Network Address Translation from IPv6 Clients to IPv4 Servers
|
|
| RFC 6303 | Locally Served DNS Zones
|
|
| RFC 6594 | Use of the SHA-256 Algorithm with RSA, Digital Signature Algorithm (DSA), and Elliptic Curve DSA (ECDSA) in SSHFP Resource Records
|
|
| RFC 6605 | Elliptic Curve Digital Signature Algorithm (DSA) for DNSSEC
|
|
| RFC 6672 | DNAME Redirection in the DNS
|
|
| RFC 6698 | The DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS) Protocol: TLSA
|
|
| RFC 6761 | Special-Use Domain Names
|
|
| RFC 6781 | DNSSEC Operational Practices, Version 2
|
|
| RFC 6840 | Clarifications and Implementation Notes for DNS Security (DNSSEC)
|
|
| RFC 6844 | DNS Certification Authority Authorization (CAA) Resource Record
|
|
| RFC 6891 | Extension Mechanisms for DNS (EDNS(0))
|
|
| RFC 7129 | Authenticated Denial of Existence in the DNS
|
|
| RFC 7218 | Adding Acronyms to Simplify Conversations about DNS-Based Authentication of Named Entities (DANE)
|
|
| RFC 7314 | Extension Mechanisms for DNS (EDNS) EXPIRE Option
|
|
| RFC 7479 | Using Ed25519 in SSHFP Resource Records
|
|
| RFC 7553 | The Uniform Resource Identifier (URI) DNS Resource Record
|
|
| RFC 7583 | DNSSEC Key Rollover Timing Considerations
|
|
| RFC 7671 | The DNS-Based Authentication of Named Entities (DANE) Protocol: Updates and Operational Guidance
|
|
| RFC 7766 | DNS Transport over TCP - Implementation Requirements
|
|
| RFC 7793 | Adding 100.64.0.0/10 Prefixes to the IPv4 Locally-Served DNS Zones Registry
|
|
| RFC 7816 | DNS Query Name Minimisation to Improve Privacy
|
|
| RFC 7830 | The EDNS(0) Padding Option
|
|
| RFC 7871 | Client Subnet in DNS Queries
|
|
| RFC 7858 | Specification for DNS over Transport Layer Security (TLS)
|
|
| RFC 8080 | Edwards-Curve Digital Security Algorithm (EdDSA) for DNSSEC
|
|
| RFC 8109 | Initializing a DNS Resolver with Priming Queries
|
|
| RFC 8375 | Special-Use Domain 'home.arpa.'
|
|
| RFC 8484 | DNS Queries over HTTPS (DoH)
|
|
| RFC 8709 | Ed25519 and Ed448 Public Key Algorithms for the Secure Shell (SSH) Protocol
|
|
| RFC 8767 | Serving Stale Data to Improve DNS Resiliency
|
|
| RFC 8806 | Running a Root Server Local to a Resolver
|
|
| RFC 8914 | Extended DNS Errors
|
|
| RFC 8945 | Secret Key Transaction Authentication for DNS (TSIG)
|
|
| RFC 8976 | Message Digest for DNS Zones
|
|
| RFC 9103 | DNS Zone Transfer over TLS
|
|
| RFC 9156 | DNS Query Name Minimisation to Improve Privacy
|
|
| RFC 9250 | DNS over Dedicated QUIC Connections
|
|
| RFC 9276 | Guidance for NSEC3 Parameter Settings
|
|
| RFC 9432 | DNS Catalog Zones
|
|
| RFC 9520 | Negative Caching of DNS Resolution Failures
|
|
| RFC 9460 | Service Binding and Parameter Specification via the DNS (SVCB and HTTPS Resource Records)
|
|
| RFC 9609 | Initializing a DNS Resolver with Priming Queries
|
|
| draft-vixie-dnsext-dns0x20 | Use of Bit 0x20 in DNS Labels to Improve Transaction Identity
|
|
|
|
The following is a list that the DHCP Server included with the Technitium DNS Server implements.
|
|
|
|
| RFC | Title |
|
|
|----------|-----------------------------------------------------------------------------------------------------------------|
|
|
| RFC 2131 | Dynamic Host Configuration Protocol
|
|
| RFC 2132 | DHCP Options and BOOTP Vendor Extensions
|
|
| RFC 3396 | Encoding Long Options in the Dynamic Host Configuration Protocol (DHCPv4)
|
|
| RFC 3397 | Dynamic Host Configuration Protocol (DHCP) Domain Search Option
|
|
| RFC 3442 | The Classless Static Route Option for Dynamic Host Configuration Protocol (DHCP) version 4
|
|
| RFC 4702 | Client Fully Qualified Domain Name(FQDN) Option
|
|
| RFC 5417 | Control And Provisioning of Wireless Access Points (CAPWAP) Access Controller DHCP Option
|
|
| RFC 5859 | TFTP Server Address Option for DHCPv4
|